Back to overview
Degraded

Core HR and Team Scheduling Services

Nov 06 at 06:38am EST
Affected services
Workforce Management
CoreHR

Resolved
Nov 06 at 07:17am EST

CoreHr and Team Scheduling Service issues resolved

Created
Nov 06 at 06:38am EST

We have identified an issue with our CoreHR and Team Scheduling Services. The team are currently investigating