Back to overview
Degraded
Degradation in schedule and TeamHub
Jan 20 at 09:57am EST
Affected services
Workforce Management
TeamHub
Resolved
Jan 20 at 12:29pm EST
We have resolved both issues impacting customers on our Workforce Management platform: schedule loading issues and TeamHub issues. Our team is continuing to monitor performance to ensure our systems remain fully functional.
Affected services
Workforce Management
TeamHub
Created
Jan 20 at 09:57am EST
We are currently experiencing moderate platform degradation, which is causing issues with manager approvals in TeamHub and schedules to load slowly or not at all in Harri. Our team is actively investigating this issue and we hope to have it resolved soon.
Affected services
Workforce Management
TeamHub