Back to overview
Downtime

Harri is currently experiencing downtime

Jul 25 at 12:06pm EDT
Affected services
Login & SSO
Talent Acquisition
Workforce Management
CoreHR
Carri
HarriIQ

Resolved
Jul 25 at 12:55pm EDT

We have resolved the issues causing downtime and degradation on the Harri platform, and our team has confirmed that all systems are functioning as normal.

Updated
Jul 25 at 12:29pm EDT

The Harri system is beginning to recover. Some services may continue to experience degradation or slowness during this period, but we expect to have this issue fully resolved shortly.

Created
Jul 25 at 12:06pm EDT

Harri is currently experiencing downtime, preventing users from accessing Harri services. Our team is actively investigating this issue and working towards resolution. We apologize for the inconvenience.