Back to overview
Degraded

Ongoing platform-wide degradation due to AWS outage

Oct 20 at 03:10am EDT
Affected services
Talent Acquisition
Workforce Management
CoreHR
Carri
TeamHub
HarriIQ

Resolved
Oct 20 at 05:48pm EDT

AWS has fully resolved the outage, and we have confirmed that performance has returned to pre-event levels. Our team continues to closely monitor the system to ensure systems remain fully operational.

Created
Oct 20 at 03:10am EDT

We are currently experiencing performance issues due to a widespread outage with our cloud provider, Amazon Web Services (AWS). Our team is actively monitoring the situation and working to restore full service as quickly as possible. We thank you for your patience and apologize for any inconvenience.