Back to overview
Downtime
Harri is experiencing platform degradation
Mar 23, 2026 at 04:41pm UTC
Affected services
Workforce Management
CoreHR
TeamHub
Resolved
Mar 23, 2026 at 05:39pm UTC
We have identified the root cause of the issue causing degradation and implemented a fix. Systems are returning to normal, and our team will continue to monitor system health to ensure a full recovery.
Affected services
Created
Mar 23, 2026 at 04:41pm UTC
We are currently experiencing platform degradation impacting the Harri Workforce Management module. Our team is currently investigating this issue and working to implement a fix as soon as possible.
Affected services